Excel – função somarproduto

 

ica da Alene para o blog espero que gostem

Ao invéz de ficar fazendo várias fórmulas SE em uma para obter várias condições de uma vez só vc pode usar apenas a fórmula do “SOMARPRODUTO” essa sim é mamão com açúcar no dia a dia da gente, olha só vou dar um exemplo (vou fazer um exemplo só com 2 condições pra ficar menor a fórmula, mas vc pode colocar qtas condições vc quiser, basta seguir o padrão):

……A………..B………..C…………….D………

1IMÓVEL…..COR……ENDEREÇO……..VALOR
2…CASA………ROSA….RUA BANGU……13.000,00
3…APTº……….ROSA….RUA BRINCO…..15.000,00
4…CASA………AZUL….RUA E…………….20.000,00
5…CASA………ROSA….RUA OURO……..50.000,00

 

Vamos lá suponhamos que os dados acima seja minha tabela e eu quero comprar todas as “casa” que sejam “rosa”, quanto ficaria pra comprar todas?

eis a fórmula mágica:

=SOMARPRODUTO(–(A2:A5=”CASA”);–(B2:B5=”ROSA”);(D2:D5))

é isso aí, reparem que sempre o último parenteses não começa com “–”, porque? pq a fórmula reconhece “–” antes do “()” como sendo mais uma condição, no caso acima ele vai somar o valor da coluna “D” toda vez que encontrar as condições na coluna “A” e na coluna “B” caso contrário ela nao soma,  para ter mais condições basta vc continuar com a sequência “;–(intervalo_de_linha e a condição)” prontinho.

LEMBRETES IMPORTANTES SOBRE A FÓRMULA:

*** se vc for avaliar valores numéricos não usa-se “” aspas na condição, usa-se somento o numero a ser avaliado.
exemplo:
=SOMARPRODUTO(–(A2:A5=1);–(B2:B5<5);(D2:D5))
neste caso se na coluna “A” for 1 e na coluna B estiver menor que 5 vai somar o valor da col D.

*** se a condição que vc quer varia basta substituir o =”casa” por =B5, assim ela vai procurar o que estiver na célula B5, claro que vc pode mudar pra qualquer outra célula.
exemplo:
=SOMARPRODUTO(–(A2:A5=B5);–(B2:B5<5);(D2:D5))
neste caso se na coluna “A” for igual a célula B5 e na coluna B estiver menor que 5 vai somar o valor da col D.

…lembrando que se vc não quer que a fórmula mude o B5 quando a fórmula for arrastada pra copiar pra outras células tem que add o $ antes do B e antes do 5, ficará assim: $B$5 (essa vale pra qualquer fórmula táh!?)

*** Os intervalos de linhas tem que ser sempre os mesmos.
exemplo:
=SOMARPRODUTO(–(A2:A100=1);–(B2:B100<5);(D2:D100))
se tiver com intervalos diferentes a fórmula vai retornar: #VALOR!
exemplo da fórmula errada:
=SOMARPRODUTO(–(A2:A100=1);–(B2:B100<5);(D2:D112))

É isso aí galerinha, aposto que vai ser muito útil essa fórmula!!!

2 comentários sobre “Excel – função somarproduto

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s